unable to hear caller's voice and the caller also unable to hear my voice

20 posts / 0 new
Last post
winanjaya
winanjaya's picture
unable to hear caller's voice and the caller also unable to hear my voice

Hello All,

I installed FreePBX that comes with AsteriskNOW-1.5.0-i386-1of1.iso, everythings installed with no error or warning..

I am using X-Lite 3.0 Build 56125, I am sure that my notebooks' speaker and microphone is working properly but why I am unable to hear caller's voice and the caller also unable to hear my voice ;>(

what I missed?

please help

thanks a lot in advance

Regards
Winanjaya

ClemFrSF
ClemFrSF's picture
unable to hear caller's voice....

Hello Winanjaya,

Can you hear properly the ringing sound ?
What is the FreePBX version that you use?

Thank you.
ClemFrSF.

winanjaya
winanjaya's picture
Q:Can you hear properly the

Q:Can you hear properly the ringing sound ?
A:Yes, I can hear properly the ringing and also the dial tone.

but I cannot hear the caller's voice and the caller is also unable to hear my voice.

I also had natted the public ip 202.1.2.3 to 172.16.1.230/255.255.255.255

any idea?

thanks & regards

ezz
ezz's picture
I'm not an expert but I run

I'm not an expert but I run into the same problem.. if the client is behind a NAT then you need to specify your public IP in sip_nat.conf:

externip=xxx.xxx.xxx.xxx
localnet=192.168.0.0/255.255.255.0

You also need to open port 5060 for SIP and 10000 to 20000 for RTP.

if you and client are not behind a NAT, then when you creating an extension using FreePBX, make sure that nat = no

by default, in FreePBX, nat = yes

hope this helps

winanjaya
winanjaya's picture
my clients are behind nat I

my clients are behind nat

I also had configured NAT on FreePBX -> Tools -> Asterisk SIP settings

NAT = yes
IP Configuration = static ip
external ip=202.1.2.3
local networks=172.16.1.0/255.255.255.0

and I also had configured nat=yes on each extensions

I still unable to hear the voice and the caller also unable hear my voice ;<(

I already accepted all firewall rules

# Generated by iptables-save v1.3.5 on Wed May 5 09:32:47 2010
*filter
:INPUT ACCEPT [63967:10066600]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [45146:9662847]
COMMIT
# Completed on Wed May 5 09:32:47 2010
# Generated by iptables-save v1.3.5 on Wed May 5 09:32:47 2010
*mangle
:PREROUTING ACCEPT [63973:10067368]
:INPUT ACCEPT [63968:10066640]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [45150:9663547]
:POSTROUTING ACCEPT [45165:9666585]
COMMIT
# Completed on Wed May 5 09:32:47 2010
# Generated by iptables-save v1.3.5 on Wed May 5 09:32:47 2010
*nat
:PREROUTING ACCEPT [2140:318359]
:POSTROUTING ACCEPT [95:10197]
:OUTPUT ACCEPT [95:10197]
COMMIT
# Completed on Wed May 5 09:32:47 2010

what I missed?

winanjaya
winanjaya's picture
googling and found STUN ? is

googling and found STUN ? is it because of behind NAT and it requires STUN server?..

How to configure STUN in FreePBX?

any body please help??

thanks & regards
Winanjaya

mickecarlsson
mickecarlsson's picture
You need to open UDP 5060

You need to open UDP 5060 and UDP 10000 - 20000 on your firewall.

Mikael Carlsson
(I am off-line, tinkering with my Chevy and my radios, don't know when I will be back)

winanjaya
winanjaya's picture
yes, I have opened it .. but

yes, I have opened it .. but still not working..

[root@localhost asterisk]# iptables-save
# Generated by iptables-save v1.3.5 on Wed May 5 12:22:56 2010
*filter
:INPUT ACCEPT [0:0]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [1704:241359]
-A INPUT -m state --state NEW,RELATED,ESTABLISHED -j ACCEPT
-A INPUT -p icmp -j ACCEPT
-A INPUT -i lo -j ACCEPT
-A INPUT -p udp -m udp --dport 5060 -j ACCEPT
-A INPUT -p udp -m udp --dport 10000:20000 -j ACCEPT
-A INPUT -j REJECT --reject-with icmp-port-unreachable
COMMIT
# Completed on Wed May 5 12:22:56 2010
# Generated by iptables-save v1.3.5 on Wed May 5 12:22:56 2010
*mangle
:PREROUTING ACCEPT [26514:2507779]
:INPUT ACCEPT [26514:2507779]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [1715:242843]
:POSTROUTING ACCEPT [1715:242843]
COMMIT
# Completed on Wed May 5 12:22:56 2010
# Generated by iptables-save v1.3.5 on Wed May 5 12:22:56 2010
*nat
:PREROUTING ACCEPT [2196:329364]
:POSTROUTING ACCEPT [31:2038]
:OUTPUT ACCEPT [31:2038]
COMMIT
# Completed on Wed May 5 12:22:56 2010
[root@localhost asterisk]#

ezz
ezz's picture
You don't need stun to make

You don't need stun to make this to work.

Are you using the same linux server as firewall? does your ISP connected directly to this server?

Do you have any other router/firewall?

winanjaya
winanjaya's picture
ISP (202.1.2.1/28) -> Router

ISP (202.1.2.1/28) -> Router -> Linux Firewall (172.16.1.1) -> Linux FreePBX (172.16.1.230)

I natted 202.1.2.3 to 172.16.1.230 on Linux Firewall (172.16.1.1)

iptables-save on 172.16.1.1

[root@firewallpix ~]# iptables-save
# Generated by iptables-save v1.4.1.1 on Wed May 5 13:20:53 2010
*nat
:PREROUTING ACCEPT [7494:658815]
:POSTROUTING ACCEPT [885:52257]
:OUTPUT ACCEPT [10:1281]
:NAT - [0:0]
-A PREROUTING -d 202.1.2.1/28 -i eth0 -j NAT
-A POSTROUTING -o eth0 -j MASQUERADE
-A NAT -d 202.1.2.3/32 -i eth0 -p udp -m udp -j DNAT --to-destination 172.16.1.230
-A NAT -j DROP
COMMIT
# Completed on Wed May 5 13:20:53 2010
# Generated by iptables-save v1.4.1.1 on Wed May 5 13:20:53 2010
*mangle
:PREROUTING ACCEPT [295159:93146209]
:INPUT ACCEPT [14814:1377297]
:FORWARD ACCEPT [270018:91096231]
:OUTPUT ACCEPT [418:61843]
:POSTROUTING ACCEPT [270317:91153946]
COMMIT
# Completed on Wed May 5 13:20:53 2010
# Generated by iptables-save v1.4.1.1 on Wed May 5 13:20:53 2010
*filter
:INPUT ACCEPT [0:0]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [354:56057]
-A INPUT -m state --state NEW,RELATED,ESTABLISHED -j ACCEPT
-A INPUT -p icmp -j ACCEPT
-A INPUT -i lo -j ACCEPT
-A INPUT -s 172.16.1.0/24 -p tcp -m tcp --dport 22 -m state --state NEW -j ACCEPT
ACCEPT
-A INPUT -j REJECT --reject-with icmp-port-unreachable
-A FORWARD -i eth0 -o bond1 -m state --state NEW,RELATED,ESTABLISHED -j ACCEPT
-A FORWARD -i bond1 -o eth0 -j ACCEPT
-A FORWARD -s 172.16.1.230/32 -d 0.0.0.0/32 -j ACCEPT
-A FORWARD -s 172.16.1.0/24 -j REJECT --reject-with icmp-port-unreachable
COMMIT
# Completed on Wed May 5 13:20:53 2010
[root@firewallpix ~]#

iptables-save on 172.16.1.230

[root@localhost asterisk]# iptables-save
# Generated by iptables-save v1.3.5 on Wed May 5 12:22:56 2010
*filter
:INPUT ACCEPT [0:0]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [1704:241359]
-A INPUT -m state --state NEW,RELATED,ESTABLISHED -j ACCEPT
-A INPUT -p icmp -j ACCEPT
-A INPUT -i lo -j ACCEPT
-A INPUT -p udp -m udp --dport 5060 -j ACCEPT
-A INPUT -p udp -m udp --dport 10000:20000 -j ACCEPT
-A INPUT -j REJECT --reject-with icmp-port-unreachable
COMMIT
# Completed on Wed May 5 12:22:56 2010
# Generated by iptables-save v1.3.5 on Wed May 5 12:22:56 2010
*mangle
:PREROUTING ACCEPT [26514:2507779]
:INPUT ACCEPT [26514:2507779]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [1715:242843]
:POSTROUTING ACCEPT [1715:242843]
COMMIT
# Completed on Wed May 5 12:22:56 2010
# Generated by iptables-save v1.3.5 on Wed May 5 12:22:56 2010
*nat
:PREROUTING ACCEPT [2196:329364]
:POSTROUTING ACCEPT [31:2038]
:OUTPUT ACCEPT [31:2038]
COMMIT
# Completed on Wed May 5 12:22:56 2010
[root@localhost asterisk]#

ezz
ezz's picture
what kind of router you got?

what kind of router you got? maybe you need to open port on the router too..

you need to first test to see if it's the firewall that's causing this or not... so maybe you can have the Asterisk box in DMZ or something and see if it continues to happen...

and you can actually install Wireshark on both Client PC and yours... you can actually install one on the server too... it will really help you troubleshoot this...

but again as other people also mentioned, this sounds like a firewall issue.

winanjaya
winanjaya's picture
just want to share ;>) this

just want to share ;>)
this problem resolved! .. by this simple iptables below:

[root@localhost ~]# iptables-save
# Generated by iptables-save v1.3.5 on Wed May 5 21:07:10 2010
*filter
:INPUT ACCEPT [0:0]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [53842:10898017]
-A INPUT -m state --state NEW,RELATED,ESTABLISHED -j ACCEPT
-A INPUT -p icmp -j ACCEPT
-A INPUT -i lo -j ACCEPT
-A INPUT -p udp -m udp -j ACCEPT
-A INPUT -p tcp -m tcp -j REJECT --reject-with icmp-port-unreachable
COMMIT
# Completed on Wed May 5 21:07:10 2010
# Generated by iptables-save v1.3.5 on Wed May 5 21:07:10 2010
*mangle
:PREROUTING ACCEPT [54737:10879122]
:INPUT ACCEPT [54737:10879122]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [53844:10898265]
:POSTROUTING ACCEPT [53844:10898265]
COMMIT
# Completed on Wed May 5 21:07:10 2010
# Generated by iptables-save v1.3.5 on Wed May 5 21:07:10 2010
*nat
:PREROUTING ACCEPT [247:36220]
:POSTROUTING ACCEPT [51:3686]
:OUTPUT ACCEPT [51:3686]
COMMIT
# Completed on Wed May 5 21:07:10 2010
[root@localhost ~]#

gxtech
gxtech's picture
Save problem here

Hi guys, hope someone can help.

I have got the same problem but I am not using any firewall. Just a router.

Everything is working perfect but the incoming caller cannot hear me at all. Will try tomorrow disable nat on freepbx.

Is there anything else I could try?

Thanks

winanjaya
winanjaya's picture
Hi, you also have to make

Hi,
you also have to make sure that the ISP does not block UDP..

gxtech
gxtech's picture
thanks for replying... I

thanks for replying... I have tcp/udp open from 5000 to 6000 for my didx.

SkykingOH
SkykingOH's picture
You only need udp 5060 for

You only need udp 5060 for SIP and 10000-20000 udp for RTP

You can lower the rtp range in/etc/asterisk/rtp.conf

jeremyr
jeremyr's picture
I have a similar problem

I have a similar problem where there is no audio. I make an outbound call, I hear ringing but when the call is picked up neither side can hear.

The difference is that I can put them on hold and they can hear the MOH audio and then if I take them off hold everything is fine. Both sides have audio.

Is this related?

I'm running Freeswitch and FreePBX v3

ali.nust
ali.nust's picture
Asterisk Run from localhost not From Static Ip of Server

Hi

I have installed AsteriskNOW and have successfull access to my FreepBX tooo but my Asterisk do not Run from Static ip of server (machine) it give error

== Connect attempt from '127.0.0.1' unable to authenticate
== Connect attempt from '127.0.0.1' unable to authenticate
== Connect attempt from '127.0.0.1' unable to authenticate
== Connect attempt from '127.0.0.1' unable to authenticate

Can anybody help me in this regards
Thanks

ali hussain

ali.nust
ali.nust's picture
Solution

i thing i was on mistake probably asterisk server on local server and we access it from static remote IP.

ali hussain

mbrevda
mbrevda's picture
ali.nust, please start a new

ali.nust, please start a new thread if you are having a different issue