Voicemail to email

13 posts / 0 new
Last post
Raven2m
Raven2m's picture
Voicemail to email

I'm currently running FreePBX 2.9.0.7 and have our voicemail setup to send all messages to users email and delete the msg from the voicemail box. Right now the message gets sent to the users email with the default msg, but I am looking for a way to include the callers phone number also, right now all it shows is the Caller ID name. I sure this is a easy fix by editing a config file.
Thanks in advance

Raven2m
Raven2m's picture
What config file controls

What config file controls what is included in the body of the email when freepbx sends voicemail to email?

mickecarlsson
mickecarlsson's picture
/etc/asterisk/vm_email.inc

/etc/asterisk/vm_email.inc

Mikael Carlsson
(I am off-line, tinkering with my Chevy and my radios, don't know when I will be back)

michigantelephone
michigantelephone's picture
Did anyone ever find a

Did anyone ever find a solution for this? I just had a user ask about this today, and they are on a system running FreePBX 2.8.1.4. They say they used to get the number of the caller in the e-mail, but now all they get is the name (which is often just a city name or worse). I see where the /etc/asterisk/vm_email.inc file uses a variable called ${VM_CALLERID} to determine what is sent, but I can't figure out where that variable is getting set in the first place.

mickecarlsson
mickecarlsson's picture
It is from within

It is from within app_voicemail.so. In FreePBX the file voicemail.conf is split into three different files, two are included in voicemail.conf.

All variables are documented here: http://www.voip-info.org/wiki/view/Asterisk+config+voicemail.conf

Mikael Carlsson
(I am off-line, tinkering with my Chevy and my radios, don't know when I will be back)

michigantelephone
michigantelephone's picture
Okay, figured it out, though

Okay, figured it out, though I am puzzled why it just now manifested. What was happening was that it was ignoring the contents of /etc/asterisk/vm_email.inc altogether, and using the default text from app.voicemail.so (the body of the message has the phrase "Just wanted to let you know you were just left..." if this occurs). Apparently at some point in the past, some other program or I had inserted the following at the end of /etc/asterisk/vm_general.inc:

[zonemessages]
eastern=America/New_York|'vm-received' Q 'digits/at' IMp
central=America/Chicago|'vm-received' Q 'digits/at' IMp
mountain=America/Denver|'vm-received' Q 'digits/at' IMp
pacific=America/Los_Angeles|'vm-received' Q 'digits/at' IMp

I don't even remember anymore why that was there (although my guess is that I was attempting to get it to play the proper time the call was received for a user in a different time zone), but apparently it is (or was) a valid thing to have in voicemail.conf, however for some reason the presence of this section in vm_general.inc started causing voicemail.conf to ignore vm_email.inc, even though that's a completely different file. Commenting out those lines caused it to start recognizing vm_email.inc again

I notice that now there is an empty [zonemessages] section at the bottom of the main voicemail.conf file, under the individual extension settings. I wonder if that's what caused the conflict. Anyway, I'm assuming that voicemail.conf is written by FreePBX so you can't make any changes there, so, how would you go about populating the [zonemessages] section of that file with any rules you may wish to add there? If there's a place to do it in the FreePBX GUI, I'm at a loss to find it. EDIT: I see now that the "Voicemail Admin" module has a "Timezone Definitions" section. I wonder if maybe installing that module on a 2.8 system (where it's still listed as being a third-party module) may have precipitated this issue? In any case, attempting add a timezone definition from within that module seems to do absolutely nothing (the Voicemail Admin module version is 2.5.7.1). However, I found that if I added them manually at the bottom of voicemail.conf, then that version of the Voicemail Admin module recognizes them. Go figure.

In any case, for anyone else having the problem, make sure you don't have anything extra in your vm_general.inc file.

Raven2m
Raven2m's picture
Thanks for the info

Thanks for the info, my users are much happier having their voicemail emails now with CID name & number.

bighersh
bighersh's picture
/etc/asterisk/vm_email.inc totally ignored

I got the same problem and don't know where to start.

Raven2m
Raven2m's picture
Caller ID Name & Number

All I did was to edit /etc/asterisk/voicemail.conf look for the emailbody= line (about 2 pages down) and add ${VM_CIDNUM} after ${VM_CIDNAME} to have Caller ID name and number listed in the email.

bighersh
bighersh's picture
Cid name and number

they are 2 lines emailbody=, 146and 151. I'm wondering, the whole file is a commented out, also according to what i understand, is not the vm_email.inc, responsibe for this action? what causes it to be over looked?
something is a bit confusing to me...
Sorry and thanks,

bighersh
bighersh's picture
Caller ID name and number

Sorry, forgot to state I tried both and didn't work.
Thanks

dbonilla
dbonilla's picture
Has anyone fix this issue?

Has anyone fix this issue? Still having this issue getting voicemail with the caller id name but not the caller id number.

Any advise?

dbonilla
dbonilla's picture
Ok, Got it working

I edit the /etc/asterisk/voicemail.conf look for the emailbody= (line) it was comment-out, i had to take the comment-out them reload the voicemail module from the * CLI module reload app_voicemail.so, Done!!!

now i'm getting callerid name and Caller id number.