Endpoint Manager not working

11 posts / 0 new
Last post
stxconsulting
stxconsulting's picture
Endpoint Manager not working

I've searched for an existing issue... but have not found anything like what I'm experiencing.

When I go to endpoint manager The page shows the following:
---------------------------------------------------------------------------
Welcome to Endpoint Manager!
You have no products (Modules) installed, click here to install some
---------------------------------------------------------------------------
When I click to install it sits and seems to hang then I get the following message:

---------------------------------------------------------------------------
Server Replied with error ''. Unable to download files
Not able to connect to repository. Using local master file instead.

Not able to connect to repository. Using local Provisioner.net Package

Aborting Brand Downloads. Can't Get Master File, Assuming Timeout Issues!

Learn how to manually upload packages here (it's easy!): Click Here!
---------------------------------------------------------------------------

I can't seem to get any modules to upload to configure phones using this module. Is there a fix or update that needs to be applied? BTW: my dns is setup properly and everything else works real good.

Thomas

tm1000
tm1000's picture
You php server (apache +

You php server (apache + php) is unable to use fopen. Instead it's getting a timeout error. This is unfortunately your server's problem as it means PHP doesn't have proper DNS and therefore can't connect to mirror.freepbx.org/provisioner/v3

Senior Developer
Schmoozecom, INC

stxconsulting
stxconsulting's picture
DNS is working

DNS is working... mirror.freepbx.org resolves to 199.102.239.158 which does not respond to pings.

I've tried pinging 199.102.239.158 directly and it does not respond to pings.

Attempted from TWO seperate ISP's with same response.

Thank you.

tm1000
tm1000's picture
It won't respond to pings

It won't respond to pings because its behind a firewall and we block those things. You can still resolve the URL and the directory it's trying to access is visible. The code works. It's something on your server unfortunately.

Senior Developer
Schmoozecom, INC

stxconsulting
stxconsulting's picture
OK...

Ok, I tried a wget and the domain does resolve on the FreePBX box and I can download files using wget.

This is NOT a dns issue nor is it an issue of my server being able to download files from your site. This is an issue with the Endpoint Manager.

Is there an updated version of the module I should be using?

Thanks.

tm1000
tm1000's picture
If its an issue with

If its an issue with endpoint don't you think more people would be reporting it? Sorry but its not. Plenty of people use it daily. Just fine.

Senior Developer
Schmoozecom, INC

jfvanderschaaf
jfvanderschaaf's picture
Actually, I have the same

Actually,

I have the same problem here. DNS works fine, can resolve mirror.freepbx.org without any problems to 199.102.239.158.

Endpoint manager however gives the same error as OP.

tm1000
tm1000's picture
And yet in between the 15

And yet in between the 15 days I last responded to this thread I've talked to 10 people who have set it up just fine. The problem is your server + dns + php fopen resolvers

Senior Developer
Schmoozecom, INC

stxconsulting
stxconsulting's picture
fopen is not the issue

tm1000, my issue is not fopen, dns or php.

I've tested all of these and i am getting "OK" when opening mirror.freepbx.org on port 80.

Something else is going on. I'm looking for other direction... not a flat-out statement "assuming" it has to be the end-users installation. In fact, the install was setup using FreePBX ISO distribution. I could understand a setup issue if I did the install manually. If you are telling me it is my install, then there is an obvious issue with the ISO from FreePBX.

Thank you.

Thomas

jfvanderschaaf
jfvanderschaaf's picture
Any idea how I can pinpoint

Any idea how I can pinpoint the problem?

I can wget http://mirror.freepbx.org/provisioner/v3/provisioner_net.tgz just fine. Even though I read about some issues with Sonicwalls, the md5 hash is the same, compared to the md5 hash when I download this file at home.

DNS seems fine. No Content Filtering or firewall rules blocking anything from freepbx.org.

tachikoma
tachikoma's picture
Thanks for the bit about the

Thanks for the bit about the Sonicwall...
I was having the same problem with my endpoint/firmware downloads and so I allowed the PBX through the Sonicwall CFS. Now it works like it should.